Forum

Einloggen | Registrieren | RSS  

Willy

07.07.2018,
14:42
 

(NEUER) Frequenzgenerator - wieder ein kleines Problemchen! (Elektronik)

Hallo!!

Nachdem mein "alter" Frequenzgenerator ja einige Macken hatte, baute ich diesen nun komplett neu auf, mit der Hoffnung auf "beseitigung" der Probleme. Hier der Link zu meinem letzten Eintrag: http://www.elektronik-kompendium.de/forum/forum_entry.php?id=261940&page=0&category=all&order=time

Nun, das Problem mit den heißen Transistoren und dem zu großen Stromfluss hat sich zumindest teilweise verringert - die Transistoren werden zwar schon noch heiß, aber es dauert zumindest einige Zeit und es ist nicht mehr so extrem. Der Stromfluss pendelt sich bei ca. 20V auf ca. 6-7A ein (bei ca. 30kHz) - nicht mehr 20A.

Leider gibts jetzt ein neues Problem: Die beiden Transistoren gehen einfach kaputt? Es hat angefangen, nachdem ich ein bisschen an der Frequenz herumgedreht hatte, jetzt liegt die Frequenz bei ca. 70kHz und sobald ich die Schaltung mit Spannung versorge, dauert es ca. 10sec, dann sind die beiden Transistoren im Himmel. Sie werden aber nicht wirklich heiß, so kann es an der Temperatur nicht liegen. Kein einziges Bauteil an der Schaltung wird heiß! Ich habe jetzt schon 3 Transistoren verloren, deswegen frage ich mal hier nach, an was es liege könnte?

Zur Schaltung: die Eingangsspannung kann zwischen 15-100V liegen, die Frequenz ist einstellbar bis ca. 120kHz über 2 Potis und über einen extra Poti kann man noch die Pulsweite einstellen. vgl. Bilder im Anhang.

Zum Trafo: Ferritkern aus Zeilentrafo mit prim. 2x9 Windungen + Mittelabgriff mit HF-Litze / sek. 1800 Windungen, 0,22mm / > KEIN LUFTSPALT <

Bitte um Ideen, an was es liegen könnte!!











JBE(R)

bei mir zu hause,
07.07.2018,
17:12
(editiert von JBE
am 07.07.2018 um 17:28)


@ Willy

(NEUER) Frequenzgenerator - wieder ein kleines Problemchen!

» Hallo!!
»
» Nachdem mein "alter" Frequenzgenerator ja einige Macken hatte, baute ich
» diesen nun komplett neu auf, mit der Hoffnung auf "beseitigung" der
» Probleme. Hier der Link zu meinem letzten Eintrag:
» http://www.elektronik-kompendium.de/forum/forum_entry.php?id=261940&page=0&category=all&order=time
»
» Nun, das Problem mit den heißen Transistoren und dem zu großen Stromfluss
» hat sich zumindest teilweise verringert - die Transistoren werden zwar
» schon noch heiß, aber es dauert zumindest einige Zeit und es ist nicht mehr
» so extrem. Der Stromfluss pendelt sich bei ca. 20V auf ca. 6-7A ein (bei
» ca. 30kHz) - nicht mehr 20A.

»
» Leider gibts jetzt ein neues Problem: Die beiden Transistoren gehen einfach
» kaputt? Es hat angefangen, nachdem ich ein bisschen an der Frequenz
» herumgedreht hatte, jetzt liegt die Frequenz bei ca. 70kHz und sobald ich

Eindeutig Kernsättigung , durch falsche Windungszahl für diese Frequenz.
Und oder die Ansteuerleistung reicht nicht mehr aus.

» die Schaltung mit Spannung versorge, dauert es ca. 10sec, dann sind die
» beiden Transistoren im Himmel. Sie werden aber nicht wirklich heiß, so kann
» es an der Temperatur nicht liegen. Kein einziges Bauteil an der Schaltung
» wird heiß! Ich habe jetzt schon 3 Transistoren verloren, deswegen frage ich
» mal hier nach, an was es liege könnte?
»
» Zur Schaltung: die Eingangsspannung kann zwischen 15-100V liegen, die
» Frequenz ist einstellbar bis ca. 120kHz über 2 Potis und über einen extra
» Poti kann man noch die Pulsweite einstellen. vgl. Bilder im Anhang.
»
» Zum Trafo: Ferritkern aus Zeilentrafo mit prim. 2x9 Windungen +
» Mittelabgriff mit HF-Litze / sek. 1800 Windungen, 0,22mm / > KEIN LUFTSPALT
» <
»
» Bitte um Ideen, an was es liegen könnte!!
»
»
»
»
»
»
»
»
»
»
»
»

Verändert man die Frequenz, und oder die Spannung muss auch die Windungszahl verändert werden bei gleichem Tastverhältnis

Im gleichen Zug muss auch die Pulsweite verändert werden.

Dein Kern ist ausserdem optimiert für die Zeilenfrequenz von 15625 Hz, und da man überhaupt keine Kerndaten hat wie z.B. AL-Wert und auch die Magnetische Induktion nicht kennt dieses Kernes, ist es Glückssache mit der Primärwindungszahl.

Dieser Kern ist Hoffnungslos überlastet. Die Induktivität bricht zusammen und es wirkt nur noch der Primärspulenwiderstand.

Was noch hinzu kommt ist die hohe sekundärspannung, die kann sich auf die Primärseite Transformieren.

Diese Spule hat auch eine Spulenkapazität, sodass bei höher werdender Frequenz auch größere Umladungen stattfinden.

Dies hat wiederrum Einfluss auf der Primärseite. Kapazitätsbelastung so kann man das nennen.

Deine Transistoren werden schlicht weg überlastest, oder gehen in den Linearen bereich.

Um das raus zu finden ist Bildgebendes Material von Nöten , Oszillografieren Notwendig.

Vielleicht kommt deine Schaltung in Resonanz, das hat natürlich eine drastische Spannungsüberhöhung zur Folge.

Alles andere ist nur ein herumgebastel was zu nichts führt.

Das einzige was du machen kannst, ohne Sekundäre Spule mal Probieren, aber dann auch mit Strombegrenzung.

--
Für Gramm-atik, Schreibrechtslinksfehler, Interp(f)unktion, KLEIN und groß Schreibwaren, fragen Sie irren Leerrehr und oder Duden.
:erregt:

Willy

07.07.2018,
18:09

@ JBE

(NEUER) Frequenzgenerator - wieder ein kleines Problemchen!

Danke für die ersten Infos!!

»
» Eindeutig Kernsättigung , durch falsche Windungszahl für diese Frequenz.
» Und oder die Ansteuerleistung reicht nicht mehr aus.
»
...hm also der kern sollte so wie er gebaut wurde inkl. Windungszahlen und von 25kHz aufwärts eigentlich gut laufen, wurde mir
zumindest in einem anderen Forum gesagt? https://www.mikrocontroller.net/topic/452644?goto=5448391#5448391


»
» Verändert man die Frequenz, und oder die Spannung muss auch die
» Windungszahl verändert werden bei gleichem Tastverhältnis

» Im gleichen Zug muss auch die Pulsweite verändert werden.

Ich dachte, die Frequenz, Spannung und Pulsweite zu ändern reicht aus in einem Bereich von 25-80kHz.
(!)WOBEI(!): die Pulsweite habe ich NICHT eingestellt, da war die Voreinstellung des Poti eingestellt, fällt mir gerade ein - also da könnte so gut wie alles eingestellt gewesen sein - kann das eventuell schuld sein an dem Problem?

» Dein Kern ist ausserdem optimiert für die Zeilenfrequenz von 15625 Hz, und
» da man überhaupt keine Kerndaten hat wie z.B. AL-Wert und auch die
» Magnetische Induktion nicht kennt dieses Kernes, ist es Glückssache mit der
» Primärwindungszahl.

Den AL-Wert werde ich noch herausbekommen, schreibe dann hier rein.

» Dieser Kern ist Hoffnungslos überlastet. Die Induktivität bricht zusammen
» und es wirkt nur noch der Primärspulenwiderstand.
»
» Was noch hinzu kommt ist die hohe sekundärspannung, die kann sich auf die
» Primärseite Transformieren.
»
» Diese Spule hat auch eine Spulenkapazität, sodass bei höher werdender
» Frequenz auch größere Umladungen stattfinden.
»
» Dies hat wiederrum Einfluss auf der Primärseite. Kapazitätsbelastung so
» kann man das nennen.
»
» Deine Transistoren werden schlicht weg überlastest, oder gehen in den
» Linearen bereich.
»
» Um das raus zu finden ist Bildgebendes Material von Nöten ,
» Oszillografieren Notwendig.
»
» Vielleicht kommt deine Schaltung in Resonanz, das hat natürlich eine
» drastische Spannungsüberhöhung zur Folge.
»
» Alles andere ist nur ein herumgebastel was zu nichts führt.
»
» Das einzige was du machen kannst, ohne Sekundäre Spule mal Probieren, aber
» dann auch mit Strombegrenzung.

Ok, werde es auch so einmal versuchen.

Was mir noch eingefallen ist:

Grundsätzlich hat meine "alte" Schaltung ja mit diesem Kern funktioniert (bei jeder Frequenz), nur wurden da die genannten Transistoren einfach viel zu heiß. Aber jetzt gehen sie (ohne groß zu erhitzen) einfach kaputt, das ist eben seltsam. Was habe ich alles geändert:

1. den Luftspalt vom Kern entfernt - ist denke ich nicht das Problem.

2. DÜNNERER Draht primär mit MEHR windungen? - draht zu dünn oder zu viele Windungen?

3. Eine "Totzeit" beim SG3525A eingestellt - eher nicht das problem?

4. Eine RC-Reihenschaltung paralell zu den Transistoren eingebaut! - kann diese schuld sein?
Da habe ich für die Kondensatoren C6 und C7 diese eingbeaut: https://www.conrad.at/de/kemet-r413f147000m1m-mkp-funkentstoer-kondensator-radial-bedrahtet-47-nf-300-v-20-10-mm-l-x-b-x-h-13-x-5-x-11-1-s-1235252.html

5. Betrieb der Schaltung mit unbekannter Pulsweiten-einstellung! - die unbekannte Pulsweite war ja fix eingestellt, nur die Frequenz habe ich geändert?

6. Vorwiderstand von 1Ohm an der Base der Transistoren.


.... vielleicht fällt noch jemand etwas dazu ein?

JBE(R)

bei mir zu hause,
07.07.2018,
21:05
(editiert von JBE
am 07.07.2018 um 21:08)


@ Willy

(NEUER) Frequenzgenerator - wieder ein kleines Problemchen!

» Danke für die ersten Infos!!
»
» »
» » Eindeutig Kernsättigung , durch falsche Windungszahl für diese Frequenz.
» » Und oder die Ansteuerleistung reicht nicht mehr aus.
» »
» ...hm also der kern sollte so wie er gebaut wurde inkl. Windungszahlen und
» von 25kHz aufwärts eigentlich gut laufen, wurde mir
» zumindest in einem anderen Forum gesagt?
» https://www.mikrocontroller.net/topic/452644?goto=5448391#5448391

Kann das auch verifiziert werden, vermutlich nein.

Denn dann müsste exakt der gleiche Aufbau gemacht worden sein. Bis auf das Layout herunter.

Wird er auch , aber auch nur wenn alles zusammenpasst, ohne entsprechenden Kerndaten keine Passende Wicklung.




»
»
» »
» » Verändert man die Frequenz, und oder die Spannung muss auch die
» » Windungszahl verändert werden bei gleichem Tastverhältnis
»
» » Im gleichen Zug muss auch die Pulsweite verändert werden.
»
» Ich dachte, die Frequenz, Spannung und Pulsweite zu ändern reicht aus in
» einem Bereich von 25-80kHz.
» (!)WOBEI(!): die Pulsweite habe ich NICHT eingestellt, da war die
» Voreinstellung des Poti eingestellt, fällt mir gerade ein - also da könnte
» so gut wie alles eingestellt gewesen sein - kann das eventuell schuld sein
» an dem Problem?

Mitunter auch ja

»
» » Dein Kern ist ausserdem optimiert für die Zeilenfrequenz von 15625 Hz,
» und
» » da man überhaupt keine Kerndaten hat wie z.B. AL-Wert und auch die
» » Magnetische Induktion nicht kennt dieses Kernes, ist es Glückssache mit
» der
» » Primärwindungszahl.
»
» Den AL-Wert werde ich noch herausbekommen, schreibe dann hier rein.

auch der millitesla B hat da noch ein Wörtchen mit zu reden.
»
» » Dieser Kern ist Hoffnungslos überlastet. Die Induktivität bricht
» zusammen
» » und es wirkt nur noch der Primärspulenwiderstand.
» »
» » Was noch hinzu kommt ist die hohe sekundärspannung, die kann sich auf
» die
» » Primärseite Transformieren.
» »
» » Diese Spule hat auch eine Spulenkapazität, sodass bei höher werdender
» » Frequenz auch größere Umladungen stattfinden.
» »
» » Dies hat wiederrum Einfluss auf der Primärseite. Kapazitätsbelastung so
» » kann man das nennen.
» »
» » Deine Transistoren werden schlicht weg überlastest, oder gehen in den
» » Linearen bereich.
» »
» » Um das raus zu finden ist Bildgebendes Material von Nöten ,
» » Oszillografieren Notwendig.
» »
» » Vielleicht kommt deine Schaltung in Resonanz, das hat natürlich eine
» » drastische Spannungsüberhöhung zur Folge.
» »
» » Alles andere ist nur ein herumgebastel was zu nichts führt.
» »
» » Das einzige was du machen kannst, ohne Sekundäre Spule mal Probieren,
» aber
» » dann auch mit Strombegrenzung.
»
» Ok, werde es auch so einmal versuchen.
»
» Was mir noch eingefallen ist:
»
» Grundsätzlich hat meine "alte" Schaltung ja mit diesem Kern funktioniert
» (bei jeder Frequenz), nur wurden da die genannten Transistoren einfach viel
» zu heiß. Aber jetzt gehen sie (ohne groß zu erhitzen) einfach kaputt, das
» ist eben seltsam. Was habe ich alles geändert:
»
» 1. den Luftspalt vom Kern entfernt - ist denke ich nicht das Problem.
»
» 2. DÜNNERER Draht primär mit MEHR windungen? - draht zu dünn oder zu viele
» Windungen?
»
» 3. Eine "Totzeit" beim SG3525A eingestellt - eher nicht das problem?
»
» 4. Eine RC-Reihenschaltung paralell zu den Transistoren eingebaut! - kann
» diese schuld sein?

Die RC Schaltung kann ein Problem werden mit zunehmender Frequenz sinkt der Widerstand, kann Auslöser sein für Resonanzfrequenz.
Deshalb sind diese Snubber nur für eine feste Frequenz geeignet.

» Da habe ich für die Kondensatoren C6 und C7 diese eingbeaut:
» https://www.conrad.at/de/kemet-r413f147000m1m-mkp-funkentstoer-kondensator-radial-bedrahtet-47-nf-300-v-20-10-mm-l-x-b-x-h-13-x-5-x-11-1-s-1235252.html
»
» 5. Betrieb der Schaltung mit unbekannter Pulsweiten-einstellung! - die
» unbekannte Pulsweite war ja fix eingestellt, nur die Frequenz habe ich
» geändert?
»
» 6. Vorwiderstand von 1Ohm an der Base der Transistoren.

Du hast MOS-FET eingebaut, dann ist dass das Gate.
»
»
» .... vielleicht fällt noch jemand etwas dazu ein?

Wie gesagt ohne Oszi , suchst du dir und wir einen Wolf.

--
Für Gramm-atik, Schreibrechtslinksfehler, Interp(f)unktion, KLEIN und groß Schreibwaren, fragen Sie irren Leerrehr und oder Duden.
:erregt:

xy(R)

E-Mail

07.07.2018,
22:00

@ JBE

(NEUER) Frequenzgenerator - wieder ein kleines Problemchen!

» Dein Kern ist ausserdem optimiert für die Zeilenfrequenz von 15625 Hz, und
» da man überhaupt keine Kerndaten hat wie z.B. AL-Wert und auch die
» Magnetische Induktion nicht kennt dieses Kernes, ist es Glückssache mit der
» Primärwindungszahl.

UR48/39/17 aus 3C30 kommt in etwa hin.

http://www.elektronik-kompendium.de/forum/upload/20180707220023.pdf

http://www.elektronik-kompendium.de/forum/upload/20180707220046.pdf

JBE(R)

bei mir zu hause,
07.07.2018,
23:14
(editiert von JBE
am 07.07.2018 um 23:20)


@ xy

(NEUER) Frequenzgenerator - wieder ein kleines Problemchen!

» » Dein Kern ist ausserdem optimiert für die Zeilenfrequenz von 15625 Hz,
» und
» » da man überhaupt keine Kerndaten hat wie z.B. AL-Wert und auch die
» » Magnetische Induktion nicht kennt dieses Kernes, ist es Glückssache mit
» der
» » Primärwindungszahl.
»
» UR48/39/17 aus 3C30 kommt in etwa hin.
»
» http://www.elektronik-kompendium.de/forum/upload/20180707220023.pdf
»
» http://www.elektronik-kompendium.de/forum/upload/20180707220046.pdf

Sieht nach Typ 1 aus was Willy da hat.

Dieser Kern kommt ganz gut einem ETD 44 nahe.
Uein min 20V Uein Max 100V , bei Uein min fließen 12 A

bei 20 KHz und 100V Eingang ergiebt einen Delta B von 347 mT , Primär 2*5 Windungen Drahtdurchmesser 3.46 mm bei S = 3A/mm² Sekundär ca 7000 Windungen
Drahtdurchmesser 0.13mm.
bei 100 KHz und 100V Eingang ergiebt einen Delta B von 132 mT Primär 2*4 Windungen Drahtdurchmesser bleibt weil ohne Skinneffekt gerechnet Sekundär 5000 Windungen.

Beide Rechnungen für 8000V Sekundär

Ein Ve von größer 20000 mm³ wird gefordert. Veoptimal 24000mm³

--
Für Gramm-atik, Schreibrechtslinksfehler, Interp(f)unktion, KLEIN und groß Schreibwaren, fragen Sie irren Leerrehr und oder Duden.
:erregt:

xy(R)

E-Mail

08.07.2018,
01:29

@ JBE

(NEUER) Frequenzgenerator - wieder ein kleines Problemchen!

» Dieser Kern kommt ganz gut einem ETD 44 nahe.

Naja, A_e und l_e sind schon deutlich verschieden.

mnemonic(R)

08.07.2018,
10:16

@ Willy

(NEUER) Frequenzgenerator - wieder ein kleines Problemchen!

Hast du die defketen Transistoren mal ausgemessen?
Ist das Gate
S-D Strecke
durchgebrochen?

--
"Immer genügend Widerstand mitbringen"

Willy

08.07.2018,
12:07

@ mnemonic

(NEUER) Frequenzgenerator - wieder ein kleines Problemchen!

Danke für alle Infos!! & danke an JBE für die Rechnung!

Jendenfalls werde ich mir die Rechnung aufheben, vielleicht bastle ich mir einen "besseren" Trafo mit ETD 49 - Kern. problematisch werden halt nur die 5000 Windungen und die Isolierung dazu, aber mal sehen, hab ja eine Menge an Draht herumliegen.

Nur möchte ich aber jetzt doch versuchen mit diesem Trafo zu arbeiten, vielleicht geht das auch irgendwie mit den 1800 Windugnen sekundär, die prim. kann ich ja jederzeit ändern - sagen wir die Spannung sekundär sollte halt 2kV mindesntens betragen, je mehr desto besser.

» Hast du die defketen Transistoren mal ausgemessen?
» Ist das Gate
» S-D Strecke
» durchgebrochen?

Ja, die - eigentlich sind es - MOSFETS (war mein Fehler in der Angabe) habe ich gemessen:

zwischen G & D sind es 320 Ohm, genauso viel zwischen G & S.
zwischen D & S sind es 0,9 Ohm.

Bei den "nicht defekten" sind es über mehrere MegaOhm.

JBE(R)

bei mir zu hause,
08.07.2018,
13:02

@ xy

(NEUER) Frequenzgenerator - wieder ein kleines Problemchen!

» » Dieser Kern kommt ganz gut einem ETD 44 nahe.
»
» Naja, A_e und l_e sind schon deutlich verschieden.

Ve ist verwendet worden der liegt bei ETD44 17800 ,und beim UR 35 bei 16600.

Von daher schenkt sich das nicht viel.

Wenn du ein besseren Vorschlag hast, dann raus damit.

--
Für Gramm-atik, Schreibrechtslinksfehler, Interp(f)unktion, KLEIN und groß Schreibwaren, fragen Sie irren Leerrehr und oder Duden.
:erregt:

JBE(R)

bei mir zu hause,
08.07.2018,
13:19

@ Willy

(NEUER) Frequenzgenerator - wieder ein kleines Problemchen!

» Danke für alle Infos!! & danke an JBE für die Rechnung!
»
» Jendenfalls werde ich mir die Rechnung aufheben, vielleicht bastle ich mir
» einen "besseren" Trafo mit ETD 49 - Kern. problematisch werden halt nur die
» 5000 Windungen und die Isolierung dazu, aber mal sehen, hab ja eine Menge
» an Draht herumliegen.
»
» Nur möchte ich aber jetzt doch versuchen mit diesem Trafo zu arbeiten,
» vielleicht geht das auch irgendwie mit den 1800 Windugnen sekundär, die
» prim. kann ich ja jederzeit ändern - sagen wir die Spannung sekundär sollte
» halt 2kV mindesntens betragen, je mehr desto besser.

Die 2000V wirst du gerade so noch hinbekommen.

Wichtig ist das du bei diesem Weitbereichseingang auch das Pulspausen Verhältniss mit Veränderst .

kleine Eingangsspannung lange Puls. hohe Eingangsspannung kurzer Puls.

Normalerweise muss diese Information dem Steuer IC mitgeteilt werden, sodass das Pulpausenverhältnis immer mit läuft , sobald sich Eingangspannung,Ausgangspannung und Last Verändern.

»
» » Hast du die defketen Transistoren mal ausgemessen?
» » Ist das Gate
» » S-D Strecke
» » durchgebrochen?
»
» Ja, die - eigentlich sind es - MOSFETS (war mein Fehler in der Angabe)
» habe ich gemessen:
»
» zwischen G & D sind es 320 Ohm, genauso viel zwischen G & S.
» zwischen D & S sind es 0,9 Ohm.
»
» Bei den "nicht defekten" sind es über mehrere MegaOhm.

--
Für Gramm-atik, Schreibrechtslinksfehler, Interp(f)unktion, KLEIN und groß Schreibwaren, fragen Sie irren Leerrehr und oder Duden.
:erregt:

xy(R)

E-Mail

08.07.2018,
14:45

@ JBE

(NEUER) Frequenzgenerator - wieder ein kleines Problemchen!

» » » Dieser Kern kommt ganz gut einem ETD 44 nahe.
» »
» » Naja, A_e und l_e sind schon deutlich verschieden.
»
» Ve ist verwendet worden der liegt bei ETD44 17800 ,und beim UR 35 bei
» 16600.
»
» Von daher schenkt sich das nicht viel.

Die Magnetisierung hängt aber nicht vom Querschnitt ab.


» Wenn du ein besseren Vorschlag hast, dann raus damit.

Ich rechne da nichts mehr, der TE soll sich ein Oszi mit HF-Stromzange besorgen.

JBE(R)

bei mir zu hause,
08.07.2018,
18:45

@ xy

(NEUER) Frequenzgenerator - wieder ein kleines Problemchen!

» » » » Dieser Kern kommt ganz gut einem ETD 44 nahe.
» » »
» » » Naja, A_e und l_e sind schon deutlich verschieden.
» »
» » Ve ist verwendet worden der liegt bei ETD44 17800 ,und beim UR 35 bei
» » 16600.
» »
» » Von daher schenkt sich das nicht viel.
»
» Die Magnetisierung hängt aber nicht vom Querschnitt ab.

Das is klar Natürlich hab ich auch den Ae berücksichtigt.


»
»
» » Wenn du ein besseren Vorschlag hast, dann raus damit.
»
» Ich rechne da nichts mehr, der TE soll sich ein Oszi mit HF-Stromzange
» besorgen.

Das ist wohl das Sinnvollste

--
Für Gramm-atik, Schreibrechtslinksfehler, Interp(f)unktion, KLEIN und groß Schreibwaren, fragen Sie irren Leerrehr und oder Duden.
:erregt:

JBE(R)

bei mir zu hause,
08.07.2018,
19:07

@ Willy

(NEUER) Frequenzgenerator - wieder ein kleines Problemchen!

» Danke für alle Infos!! & danke an JBE für die Rechnung!
»
» Jendenfalls werde ich mir die Rechnung aufheben, vielleicht bastle ich mir
» einen "besseren" Trafo mit ETD 49 - Kern. problematisch werden halt nur die
» 5000 Windungen und die Isolierung dazu, aber mal sehen, hab ja eine Menge
» an Draht herumliegen.
»
» Nur möchte ich aber jetzt doch versuchen mit diesem Trafo zu arbeiten,
» vielleicht geht das auch irgendwie mit den 1800 Windugnen sekundär, die
» prim. kann ich ja jederzeit ändern - sagen wir die Spannung sekundär sollte
» halt 2kV mindesntens betragen, je mehr desto besser.
»
» » Hast du die defketen Transistoren mal ausgemessen?
» » Ist das Gate
» » S-D Strecke
» » durchgebrochen?
»
» Ja, die - eigentlich sind es - MOSFETS (war mein Fehler in der Angabe)
» habe ich gemessen:
»
» zwischen G & D sind es 320 Ohm, genauso viel zwischen G & S.
» zwischen D & S sind es 0,9 Ohm.
»
» Bei den "nicht defekten" sind es über mehrere MegaOhm.

Ich hab mit den Kerndaten gerechnet UR 35 , dieser Kern ist nicht geeignet wenn es um optimale größe geht, von der Windungszahl her gesehen bleibt es bei 2*5 Windungen Primär, für 12 V Eingang 100 KHz, Ausgangsmäßig sind es 1860 Windungen für 2 KV.

Bei 20KHz und 12V Eingang sind es 2*8 Windungen Primär und Sekundär 2763 Windungen für 2KV


Erforderliche Eingangsdaten......................................
Ue_min = 12.00 V
Ue_max = 100.00 V
Ua = 2000.00 V
Ia = 0.03 A
f = 100000.00 Hz

Technische Kerndaten......................................
ILm1 = 10.00 A
IPa = 60.04 W
&#916;B = 131.95 mT
VeOpt = 1748 mm

Übertrager Ausgabe
Ipa = 60.04 W
Prim.Draht Ø bei S 3A/mm = 2.06 mm
Sek.Draht Ø bei S 3A/mm = 0.11 mm

N1N2.f = Ue_min.f * 0.95/(2 * (Ua.f + Uf.f)) ;Berechnung Übersetzungsverhältnis
Imax.f = Ia.f + 0.5 * dIL.f ;Berechnung max Strom
w.f = 0.5 * l.f * Imax.f * Imax.f ;Berechnung benötigte Egnergie im Kern
iPa.f = Ia.f * (Ua.f + Uf.f) ;Berechnung Ausgangsleistung
Pa.f = iPa.f/0.95 ;Berechnung max Betriebsleistung
dBOpt.f = (100 * 0.2 * Pow(50000 / f.f,0.6)) / 100 ;Berechnung optimle Flußdichtehub bei Frequenz (0,3 -0,2 T):Näherungsformel
VeOpt.f = 52000 * Pow(Pa.f / 800,1.2) * Sqr(50000 / f.f) ;Berechnung erforderliches Kernvolumen über die Leistung:Optimierung von Eisen- und Kupferverlusten Eisen+Kupferverluste=Minimum
N1P.f = ((Ue_min.f / (2*f.f * dBOpt.f * Amin.f / 1e3)) + 1);Berechnung Wdg. Primär
N2S.f = N1P.f/N1N2.f ;Berechnung Wdg. Sekundär
ILm1.f = Ua.f * Ia.f / (Ue_min.f / 2) ;Berechnung mittlerer Betriebsstrom
dprim.f = 2 * Sqr(ILm1.f / (#PI * s.f)) ;Berechnung Drahtdurchmesser Primär
dsek.f = 2 * Sqr(Ia.f / (#PI * s.f)) ;Berechnung Drahtdurchmesser Sekundär

N1P(dat_a,dat_b)=Str(N1P.f)
N2S(dat_a,dat_b)=Str(N2S.f)
DeltaB(dat_a,dat_b)=Str(dbopt.f*1e3)

--
Für Gramm-atik, Schreibrechtslinksfehler, Interp(f)unktion, KLEIN und groß Schreibwaren, fragen Sie irren Leerrehr und oder Duden.
:erregt:

Willy

08.07.2018,
19:19

@ JBE

(NEUER) Frequenzgenerator - wieder ein kleines Problemchen!

» » Ich rechne da nichts mehr, der TE soll sich ein Oszi mit HF-Stromzange
» » besorgen.
»
» Das ist wohl das Sinnvollste

Ok, ich besorge mir so ein Oszi und dann poste ich die Bilder. Anders komme ich sowieso nicht weiter, hab nun wieder einen MOSFET zerstört. Es dürfte doch an der Temperatur liegen! Ich habe einen alten AC-Zeilentrafo gefunden und den an die Schaltung angeschlossen mit primär 2x 6 Windungen. Dabei habe ich an der Frequenz un der Pulsweite herumgedreht und auch Spannungen von 20-30Volt ausgetestet.

Grundsätzlich: sobald der Poti für die Pulsweite mehr als 1/4 "aufgedreht" wird, werden die MOSFETS wieder sehr schnell sehr heiß und es fließen große Ströme von 5A aufwärts - mit erhöhung der Frequenz kann ich diese großen Ströme zwar wieder reduzieren, aber das ändert nix an der radikalen Erwärmung der MOSFETS. Ich denke, als ich den Pulsweiten-Poti ca. bis zur Hälfte "aufgedreht" hatte und die Spannung auf ca. 28Volt hochdrehte, wurde mindestens 1 MOSFET so schnell so heiß, dass er kaputt ging und diese Erwärmung dürfte auch so rasch gehen, dass man dies nicht gleich an den Kühlkörpern bemerkt. So denke ich, passiert es.

BEDEUTET: jetzt werden die MOSFETs eigentlich noch schneller heißer, als bei meiner "alten" Schaltung :( und fahren anstatt nach ca. 30 Sekunden schon nach 5 Sekunden in den Himmel. Und dem Trafo gebe ich immer weniger die Schuld, denn diesen habe ich schon mit verschiedenen primären Windungen getestet und zu guter Letzt auch einen "fertigen" AC-Zeilentrafo angeschlossen und das Ergebnis ist immer das Selbe - die MOSFETS "verdampfen".

WAS ICH JETZT MACHE: 1. Die Schaltung nochmal neu aufbauen, noch kompakter, ein besseres Layout mit der Möglichkeit die MOSFETs "einfacher" zu tauschen. 2. Ein Oszi anschließen und alles messen und dann poste ich die Bilder hier rein!

JBE(R)

bei mir zu hause,
08.07.2018,
19:51
(editiert von JBE
am 08.07.2018 um 20:24)


@ Willy

(NEUER) Frequenzgenerator - wieder ein kleines Problemchen!

» » » Ich rechne da nichts mehr, der TE soll sich ein Oszi mit HF-Stromzange
» » » besorgen.
» »
» » Das ist wohl das Sinnvollste
»
» Ok, ich besorge mir so ein Oszi und dann poste ich die Bilder. Anders komme
» ich sowieso nicht weiter, hab nun wieder einen MOSFET zerstört. Es dürfte
» doch an der Temperatur liegen! Ich habe einen alten AC-Zeilentrafo gefunden
» und den an die Schaltung angeschlossen mit primär 2x 6 Windungen. Dabei
» habe ich an der Frequenz un der Pulsweite herumgedreht und auch Spannungen
» von 20-30Volt ausgetestet.

Problem dabei ist, du kannst die Pulsweite nicht sehen, und auch nicht sehen wie die Spannung über den Transistoren aussehen.
Du siehst auch nicht ob genügend Steuerleistung vorhanden ist.

»
» Grundsätzlich: sobald der Poti für die Pulsweite mehr als 1/4 "aufgedreht"
» wird, werden die MOSFETS wieder sehr schnell sehr heiß und es fließen große
» Ströme von 5A aufwärts - mit erhöhung der Frequenz kann ich diese großen
» Ströme zwar wieder reduzieren, aber das ändert nix an der radikalen
» Erwärmung der MOSFETS. Ich denke, als ich den Pulsweiten-Poti ca. bis zur
» Hälfte "aufgedreht" hatte und die Spannung auf ca. 28Volt hochdrehte, wurde
» mindestens 1 MOSFET so schnell so heiß, dass er kaputt ging und diese
» Erwärmung dürfte auch so rasch gehen, dass man dies nicht gleich an den
» Kühlkörpern bemerkt. So denke ich, passiert es.

noch mal kleine Spannung Pulsweite groß, große Spannung Pulsweite klein.

Du hast mit größer werdender Spannung auch die Pulsweite vergrößert, das ist der Tod der Transistoren.

»
» BEDEUTET: jetzt werden die MOSFETs eigentlich noch schneller heißer, als
» bei meiner "alten" Schaltung :( und fahren anstatt nach ca. 30 Sekunden
» schon nach 5 Sekunden in den Himmel. Und dem Trafo gebe ich immer weniger
» die Schuld, denn diesen habe ich schon mit verschiedenen primären Windungen
» getestet und zu guter Letzt auch einen "fertigen" AC-Zeilentrafo
» angeschlossen und das Ergebnis ist immer das Selbe - die MOSFETS
» "verdampfen".


»
» WAS ICH JETZT MACHE: 1. Die Schaltung nochmal neu aufbauen, noch kompakter,
» ein besseres Layout mit der Möglichkeit die MOSFETs "einfacher" zu
» tauschen. 2. Ein Oszi anschließen und alles messen und dann poste ich die
» Bilder hier rein!

Du gehst zu Brutal mit deiner Schaltung um, erst wenn das Layout stimmt, die Ansteuerung der Transistoren stimmt, die Passende Pulsweite stimmt zur Eing.Spannung X
Deine Schaltung nicht anfängt zu Schwingen usw, dann klappt das auch, du siehst, dein Vorhaben wie du es gerne hättest, wird durch das Killen der Transistoren
gezeigt, das es nicht so einfach ist. Dabei kommt auch noch hinzu das keinerlei Regelschleifen vorhanden ist, Überstromschutz , automatische PWM anpassung usw.

All das macht es erst Möglich Zumindest den großen Eingangsspannungsbereich ab zu decken. Schau dich doch ganz einmal um wie es andere machen, dann wirst du sehen, welcher Aufwand aufgebracht werden muss, bis ein Schaltung funktioniert. Alle Bauteile müssen Harmonieren, wie die Musiker in einem Konzert, ist da einer dabei
der sich verspielt, ist das Konzert gegessen.

http://www.joretronik.de/Web_NT_Buch/Kap13_3/Kapitel13_3.html

--
Für Gramm-atik, Schreibrechtslinksfehler, Interp(f)unktion, KLEIN und groß Schreibwaren, fragen Sie irren Leerrehr und oder Duden.
:erregt: